Как удалить дубликаты в Excel в столбцах и строках

При работе с таблицей или базой данных с большим количеством информации возможна ситуация, когда некоторые строки повторяются. Чтобы облегчить себе выполнение задач, узнайте, как удалить дубликаты в Excel.

Как удалить дубликаты и повторяющиеся значения в Excel

Первый метод максимально прост и предполагает возможность удалить дубликаты в Excel при помощи специального инструмента на ленте вкладки “Данные”.

  1. Полностью выделяем все ячейки таблицы Excel с данными, воспользовавшись, например, зажатой левой кнопкой мыши.
  2. Во вкладке “Данные” в разделе инструментов “Работа с данными” находим кнопку “Удалить дубликаты” и кликаем на нее.
  3. Переходим к настройкам параметров для того, чтобы удалить дубликаты:
    • Если обрабатываемая таблица Excel с возможными дубликатами содержит шапку, то проверяем пункт “Мои данные содержат заголовки” – он должен быть отмечен галочкой.
    • Ниже, в основном окне, перечислены названия столбцов, по которым будет осуществляться поиск дубликатов. Система считает совпадением ситуацию, в которой в строках повторяются значения всех выбранных в настройке столбцов.  Если убрать часть столбцов из сравнения, повышается вероятность увеличения количества похожих строк.
    • Тщательно все проверяем и нажимаемОК.
  4. Далее программа Excel в автоматическом режиме найдет и удалит все дублированные строки.

Вы увидите всплывшее окно с отчетом, сколько дубликатов и повторяющихся значений было удалено в таблице Excel.

Как удалить повторения и лишние дубликаты с помощью умной таблицы

Дубликаты в программе Excel можно удалить из диапазона ячеек, создав умную таблицу.

  1. Выделяем весь табличный диапазон.
  2. Находясь во вкладке «Главная» в Excel,жмем на кнопку «Форматировать как таблицу», расположенную на ленте в блоке инструментов «Стили». В появившемся списке выбираем любой понравившийся стиль.удалить дубликаты в Excel
  3. Затем открывается небольшое окошко, в котором нужно подтвердить выбранный диапазон для формирования «умной таблицы». Если вы выделили все правильно, то можно подтверждать, если допустили ошибку, то в этом окне следует исправить. Важно также обратить внимание на то, чтобы около параметра «Таблица с заголовками»стояла галочка. Если её нет, то следует поставить. После того, как все настройки в Excel завершены, жмите на кнопку «OK». «Умная таблица» создана.повторяющиеся данные
  4. Но создание «умной таблицы» — это только один шаг для решения нашей главной задачи – мы должны удалить лишние дубликаты. Кликаем по любой ячейке табличного диапазона. При этом появляется дополнительная группа вкладок «Работа с таблицами». Находясь во вкладке «Конструктор»кликаем по кнопке «Удалить дубликаты», которая расположена на ленте в блоке инструментов «Сервис».найти и выделить
  5. После этого, открывается окно удаления дубликатов, работа с которым была подробно расписана при описании первого способа. Все дальнейшие действия производятся в точно таком же порядке.

Этот способ удалить дубликаты является наиболее универсальным и функциональным из всех описанных в данной статье. Если же что-то не выходит, уточняйте нюансы на форуме.

Задать вопрос

Как найти дубликаты в Excel и убрать их: инструкция для удаления

Следующий метод не поможет удалить мешающие дубликаты физически, но позволяет настроить режим отображения таблицы таким образом, чтобы при просмотре они скрывались.

  1. Как обычно, выделяем все ячейки таблицы.
  2. Во вкладке “Данные” в разделе инструментов “Сортировка и фильтр” ищем кнопку “Фильтр” (иконка напоминает воронку) и кликаем на нее.
  3. После этого в строке с названиями столбцов таблицы появятся значки перевернутых треугольников (это значит, что фильтр включен). Чтобы перейти к расширенным настройкам, жмем кнопку “Дополнительно“, расположенную справа от кнопки “Фильтр“.
  4. В появившемся окне с расширенными настройками:
    • как и в предыдущем способе, проверяем адрес диапазон ячеек таблицы;
    • отмечаем галочкой пункт “Только уникальные записи“;
    • жмем ОК.

После этого все дубликаты, затруднящие работу с Excel, перестанут отображаться в таблицей. Чтобы вернуться в стандартный режим, достаточно снова нажать на кнопку “Фильтр” во вкладке “Данные”.

Как удалить лишние дубликаты в Excel с помощью формулы

В Excel найти дубликаты и удалить их можно применив формулу с использованием сразу нескольких функций. С её помощью можно производить поиск дубликатов по конкретному столбцу. Общий вид данной формулы будет выглядеть следующим образом:

=ЕСЛИОШИБКА(ИНДЕКС(адрес_столбца;ПОИСКПОЗ(0;СЧЁТЕСЛИ(адрес_шапки_столбца_дубликатов: адрес_шапки_столбца_дубликатов (абсолютный); адрес_столбца;)+ЕСЛИ(СЧЁТЕСЛИ(адрес_столбца;; адрес_столбца;)>1;0;1);0));»»)

  1. Создаем отдельный столбец, куда будут выводиться дубликаты Excel, которые мы хотим удалить.
  2. Вводим формулу по указанному выше шаблону в первую свободную ячейку нового столбца. В нашем конкретном случае формула будет иметь следующий вид:

=ЕСЛИОШИБКА(ИНДЕКС(A8:A15;ПОИСКПОЗ(0;СЧЁТЕСЛИ(E7:$E$7;A8:A15)+ЕСЛИ(СЧЁТЕСЛИ(A8:A15;A8:A15)>1;0;1);0));»»)

  1. Выделяем весь столбец для дубликатов, кроме шапки. Устанавливаем курсор в конец строки формул. Нажимаем на клавиатуре кнопку F2. Затем набираем комбинацию клавиш Ctrl+Shift+Enter. Это обусловлено особенностями применения формул к массивам.

После этих действий в столбце «Дубликаты» отобразятся повторяющиеся значения. Варианты действуют для десктопа и онлайна.

эксперт
Мнение эксперта
Михаил Соловьев, консультант по вопросам работы с продуктами Microsoft
Если у вас возникнут сложности, я помогу разобраться!
Задать вопрос эксперту
Но, данный способ удалить дубликаты со страниц Excel все-таки слишком сложен для большинства пользователей. К тому же, он предполагает только поиск дублей, но не их удаление. Поэтому рекомендуется применять более простые и функциональные решения, описанные ранее. А в случае проблем обращайтесь ко мне, и я помогу разобраться.
Понравилась статья? Поделиться с друзьями:
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: