Как сравнить столбцы Excel на совпадения и дубликаты: с выделением цветом, на 2 листах

Пожалуй, каждый, кто работает с данными в Excel, сталкивается с вопросом, как сравнить два столбца в Excel на совпадения и различия. Существует несколько способов как это сделать. Давайте рассмотрим подробней каждый из них.

Как сравнить две таблицы Excel на совпадение значений в столбцах

При наличии небольшой по размеру таблицы заниматься сравнением можно практически вручную. Для этого достаточно выполнить несколько простых действий.

  1. Перейти на главную вкладку табличного процессора.
  2. В группе «Редактирование» выбрать пункт поиска.
  3. Выделить столбец, в котором будет выполняться поиск совпадений — например, второй.
  4. Вручную задавать значения из основного столбца (в данном случае — первого) и искать совпадения.

сравнить на разных листах

Если значение обнаружено, результатом станет выделение нужной ячейки. Сравнить данные в Excel подобным способом несложно.

Как сравнить совпадения и различия в строке Excel функцией ЕСЛИ

Чтобы выполнить такое построчное сравнение, используйте популярную функцию в Excel ЕСЛИ, которая позволяет сравнить первые две ячейки каждого из них. Введите её в какой-либо другой столбик той же строки, а затем скопируйте ее вниз, перетащив маркер заполнения (маленький квадрат в правом нижнем углу). При этом курсор изменится на знак плюса:

Чтобы найти в соответствующей строке позиции с одинаковым содержимым, A2 и B2 в этом примере, запишите:

=ЕСЛИ(A2=B2; «Совпадает»; «»)

Чтобы сравнить в Excel и найти позиции в одной строке с разным содержимым, просто замените «=» знаком неравенства:

=ЕСЛИ(A2<>B2; «НЕ совпадает»;””)

И, конечно же, ничто не мешает сравнить данные с помощью одной формулы:

=ЕСЛИ(A2=B2; «Совпадает»; «НЕ совпадает»)

Результат может выглядеть примерно так:

найти одинаковые значения

Как видите, одинаково хорошо обрабатываются числа, даты, время и текст.

Как еще можно сравнить различия и одинаковые значения в столбце с помощью ЕСЛИ

Еще один способ сравнить значения в двух столбцах Excel подходит для таблиц практически неограниченного размера. Он основан на применении условного оператора ЕСЛИ и отличается от других методик Excel тем, что для анализа берется только указанная в формуле часть, а не все значения массива. Порядок действий при использовании методики тоже не слишком сложный и подойдет даже для начинающего пользователя Excel.

  1. Сравниваемые столбцы Excel размещаются на одном листе. Не обязательно, чтобы они находились рядом друг с другом.
  2. В третьем столбце, например, в ячейке J6, ввести формулу такого типа: =ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(H6;$I$6:$I$14;0));»;H6)
  3. Протянуть формулу до конца столбца.

Результатом станет появление в третьей колонке всех совпадающих значений. Причем H6 в примере — это первая ячейка одного из сравниваемых столбцов. А диапазон $I$6:$I$14 — все значения второй участвующей в сравнении колонки. Функция будет последовательно сравнивать данные Excel и размещать только те из них, которые совпали. Однако выделения не происходит, поэтому методика подходит далеко не для всех ситуаций.

Как можно сравнить 2 столбца Excel на совпадения с помощью формулы ВПР

Принцип действия еще одной функции для поиска дубликатов напоминает первый способ использованием оператора ЕСЛИ. Но вместо ПОИСКПОЗ применяется ВПР, которую можно расшифровать как «Вертикальный Просмотр». Для сравнения двух столбцов из похожего примера следует ввести в верхнюю ячейку (J6) третьей колонки формулу =ВПР(H6;$I$6:$I$15;1;0) и протянуть ее в самый низ, до J15.

С помощью этой функции Excel не просто просматриваются и сравниваются повторяющиеся данные — результаты проверки устанавливаются четко напротив сравниваемого значения в первом столбце. Если программа не нашла совпадений, выдается #Н/Д.

Как найти совпадения в одной строке в любых двух столбцах таблицы Excel

Представим, что наша задача сравнить в таблице с данными в несколько столбцов те строки, в которых данные совпадают или повторяются как минимум в двух столбцах. В этом нам помогут функции ЕСЛИ и ИЛИ. Напишем формулу для таблицы, состоящей из трех столбцов с данными:

=ЕСЛИ(ИЛИ(A2=B2;B2=C2;A2=C2);”Совпадают”;” “)

В тех случаях, когда в нашей таблице слишком много столбцов – наша формула с функцией ИЛИ будет очень большой, так как в ее параметрах нам нужно указать критерии совпадения между каждым столбцом таблицы Excel. Более простой способ, в этом случае, использовать функцию СЧЁТЕСЛИ.

=ЕСЛИ(СЧЁТЕСЛИ(B2:D2;A2)+СЧЁТЕСЛИ(C2:D2;B2)+(C2=D2)=0; “Уникальная строка”; “Не уникальная строка”)

Первая функция СЧЁТЕСЛИ вычисляет количество столбцов в строке со значением в ячейке А2, вторая функция СЧЁТЕСЛИ вычисляет количество столбцов в таблице со значением из ячейки B2. Если результат вычисления равен “0” – это означает, что в каждой ячейке, каждого столбца, этой строки находятся уникальные значения. В этом случае формула выдаст результат “Уникальная строка”, если нет, то “Не уникальная строка”.

Как сравнить два столбца в Excel на совпадения и выделить цветом

Когда мы ищем дубликаты между двумя столбцами в Excel, нам может потребоваться визуализировать найденные совпадения или различия в данных, например, с помощью выделения цветом. Самый простой способ для выделения цветом совпадений и различий – использовать “Условное форматирование” в Excel. Рассмотрим как это сделать на примерах ниже.

Рассмотрим, как сравнить строки в таблице Excel:

  • Справа от таблицы с данными создадим вспомогательный столбец, в котором напротив каждой строки с данными проставим формулу, объединяющую все значения строки таблицы в одну ячейку:

=A2&B2&C2&D2

Во вспомогательной колонке вы увидите объединенные данные таблицы.

сравнить дубликаты Excel

Теперь, для того чтобы сравнить совпадающие строки в таблице Excel сделайте следующие шаги:

  • Выделите область с данными во вспомогательной колонке (в нашем примере это диапазон ячеек E2:E15);
  • На вкладке “Главная” на Панели инструментов нажимаем на пункт меню “Условное форматирование” -> “Правила выделения ячеек” -> “Повторяющиеся значения”;
  • Во всплывающем диалоговом окне выберите в левом выпадающем списке “Повторяющиеся”, в правом выпадающем списке выберите каким цветом будут выделены повторяющиеся значения. Нажмите кнопку “ОК”.
  • После этого в выделенной колонке будут подсвечены дублирующиеся строки Excel.

Если же что-то не получается, вы можете задать вопрос на форуме.

Задать вопрос

Поиск и выделение совпадений цветом в нескольких столбцах в Excel

В тех случаях, когда нам требуется найти совпадения в нескольких столбцах, то для этого нам нужно:

  • Выделить столбцы Excel с данными, в которых нужно вычислить совпадения;
  • На вкладке “Главная” на Панели инструментов нажимаем на пункт меню “Условное форматирование” -> “Правила выделения ячеек” -> “Повторяющиеся значения”;
  • Во всплывающем диалоговом окне выберите в левом выпадающем списке пункт “Повторяющиеся”, в правом выпадающем списке выберите каким цветом будут выделены повторяющиеся значения. Нажмите кнопку “ОК”:
  • После этого в выделенной колонке будут подсвечены цветом совпадения в столбцах.

сравнить столбцы

эксперт
Мнение эксперта
Михаил Соловьев, консультант по вопросам работы с продуктами Microsoft
Если у вас возникнут сложности, я помогу разобраться!
Задать вопрос эксперту
Сравнить подобным образом данные в столбцах таблицы Excel несложно. Если же что-то не получится, обращайтесь ко мне.

Как легко сравнить столбцы в разных книгах в программе Excel с помощью надстройки Inquire

Начиная с версий MS Excel 2013 табличный процессор позволяет воспользоваться еще одной методикой — специальной надстройкой Inquire. Для использования способа придется расположить столбцы или целые блоки информации в разных книгах и удалить все остальные данные, кроме сравниваемой информации. Кроме того, для проверки необходимо, чтобы оба файла были одновременно открытыми. Процесс использования надстройки включает такие действия:

  1. Перейти к параметрам электронной таблицы Excel.
  2. Выбрать сначала надстройки, а затем управление надстройками COM.
  3. Отметить пункт Inquire и нажать «ОК».
  4. Перейти к вкладке Inquire.
  5. Нажать на кнопку Compare Files, указать, какие именно файлы будут сравниваться, и выбрать Compare.
  6. В открывшемся окне Excel сравнить данные, используя показанные совпадения и различия между данными в столбцах.

У каждого варианта, который вы решили сравнить — свое цветовое решение.

 

Понравилась статья? Поделиться с друзьями:
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: