Функция ЕСЛИ в Excel: примеры, значения, как ее использовать

Логический оператор ЕСЛИ в Excel применяется для записи определенных условий. Сопоставляются цифры и/или текст, функции, формулы и т.д. Когда значения отвечают заданным параметрам, то появляется одна запись. Не отвечают – другая. Давайте же разберемся, что собой представляет функция ЕСЛИ в Excel с примерами, увидим значения и вникнем, как ее использовать.

Что такое функция ЕСЛИ в программе Excel

Функция ЕСЛИ — одна из самых популярных функций в Excel. Она позволяет выполнять логические сравнения значений и ожидаемых результатов.

Поэтому у ЕСЛИ возможны два результата. Первый результат возвращается в случае, если сравнение истинно, второй — если сравнение ложно.

Например, =ЕСЛИ(C2=»Да»;1;2) означает следующее: ЕСЛИ(С2=»Да», то вернуть 1, в противном случае вернуть 2).

Пример функции ЕСЛИ в программе Excel

Рассмотрим простой пример применения ЕСЛИ в MS Excel. У нас есть столбец №1, в котором содержатся цифры от 1 до 10. Необходимо проверить, соответствуют ли значения, находящиеся в столбце №1 нашему критерию. Критерий: является ли числа находящиеся в столбце №1 числами, значения которых больше числа 4.

Вызываем ЕСЛИ в ячейку С3.

С несколькими условиями

В диалоговом окне Аргументы функции появляются поля для заполнения:

  1. логическое_выражение—  B3>4, указан наш критерий проверки.
  2. значение_если_истина— «правда», это слово появиться в ячейки С3, если число, содержащееся в В3, больше числа 4.
  3. значение_если_ложь — «неправда», это слово появиться в ячейки С3, если число, содержащееся в ячейке В3, меньше числа 4.

Важно: текст указанный в полях «значение_если_истина» и «значение_если_ложь», должны быть заключены в кавычки. Иначе функция выдаст ошибку. 

Нажимаем ОК в диалоговом окне Аргументы функции. 

пример функции если

Как видим, число содержащееся в В3, не является числом, которое больше числа 4. Функция ЕСЛИ вернула значение_если_ложь (неправда).  Протянем функцию ЕСЛИ вниз по столбцу, чтобы проверить значения находящиеся в остальных ячейках столбца №1, на соответствие нашему критерию (логическое_выражение).

Как видно из результата, ячейки в диапазоне В7:В12 содержат в себе числа, которые больше числа 4. Функция ЕСЛИ в Excel вернула значение_если_истина (правда).

Пример функции ЕСЛИ с несколькими условиями одновременно

В функцию «ЕСЛИ» можно также вводить несколько условий. В этой ситуации применяется вложение одного оператора «ЕСЛИ» в другой. При выполнении условия в ячейке отображается заданный результат, если же условие не выполнено, то выводимый результат зависит уже от второго оператора.

  1. Для примера возьмем таблицу Excel с выплатами премии к 8 марта. Женщины, имеющие статус основного персонала, получают бонус по 1000 рублей, а вспомогательный персонал получает только 500 рублей. Естественно, что мужчинам этот вид выплат вообще не положен.
  2. Первым условием является то, что если сотрудник — мужчина, то величина получаемой премии равна нулю. Если же данное значение ложно, и сотрудник не мужчина (т.е. женщина), то начинается проверка второго условия. Если женщина относится к основному персоналу, в ячейку будет выводиться значение «1000», а в обратном случае – «500». В виде формулы это будет выглядеть следующим образом: «=ЕСЛИ(B6=»муж.»;»0″; ЕСЛИ(C6=»Основной персонал»; «1000»;»500″))».
  3. Вставляем это выражение в самую верхнюю ячейку столбца «Премия к 8 марта». РИС 3
  4. «Протягиваем» формулу вниз.

В результате вы успешно применили функцию ЕСЛИ в таблице Excel. А если что-то не получилось, задавайте свой вопрос на форуме.

Задать вопрос

Примеры несколько условий функции ЕСЛИ в Excel

Таблица Excel для анализа успеваемости. Оператор ЕСЛИ проверяет 2 условия: равенство значения в ячейке 5 и 4.

как использовать

В этом примере есть третье условие, подразумевающее наличие в табеле успеваемости еще и «двоек». Принцип «срабатывания» оператора ЕСЛИ тот же.

особенности функции если

Почему не работает функция ЕСЛИ

Функция ЕСЛИ в программе Excel может не работать по следующим причинам.

0 (ноль) в ячейке Не указан аргумент значение_если_истина или значение_если_ложь. Чтобы возвращать правильное значение, добавьте текст двух аргументов или значение ИСТИНА/ЛОЖЬ.
#ИМЯ? в ячейке Как правило, это указывает на ошибку в формуле для Excel.

Использование операторов «И» и «ИЛИ» в функции ЕСЛИ в MS Excel

эксперт
Мнение эксперта
Михаил Соловьев, консультант по вопросам работы с продуктами Microsoft
Если у вас возникнут сложности, я помогу разобраться!
Задать вопрос эксперту
У нас есть таблица Excel, в которой три столбца с числами. Проверим, равны ли эти числа между собой, в пределах одной строки. Если числа будут равны между собой, функция ЕСЛИ вернет значение «правда». Если не равны, функция ЕСЛИ вернет значение «неправда». Надеюсь, вы поняли принцип, а если остались вопросы, пишите мне, и я помогу разобраться.

Формула функции ЕСЛИ в Excel выглядит вот так:

формула если

Внимание: в данном случае формула функции ЕСЛИ прописана в ручную, прямо в строе формулы.

Сравниваются ячейки В2 с С2, С2 с ячейкой D2 и D2 с ячейкой В2. Только, если все числа в этих ячейках равны между собой, функция возвращает значение «правда». Как видно на примере, только в нижней строке таблицы (строка №4), функция ЕСЛИ вернула значение «правда», так как в этой строке все числа между собой равны.

Можно взять также оператор ИЛИ. В этом случае формула ЕСЛИ в Excel выглядит вот так:

вид если

Понравилась статья? Поделиться с друзьями:
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: