Средствами ms Excel Вычислите Значение Функций • Функция распределения

Логические функции Microsoft Excel

ПРИМЕР

=ЕСЛИ(D2=E2;1;0)
Если значения в ячейках D2 и E2 совпадают (значение
условия ИСТИНА), то функция ЕСЛИ отобразит 1.
Если значения в ячейках D2 и E2 не совпадают
(значение условия ЛОЖЬ), то функция ЕСЛИ
отобразит 0.

Логические функции
Пример. Для заданного значения
значение y по одной из формул:
x вычислить
если x > 5, то y = x — 8, иначе y = x + 3.
Знакомая нам запись решения на языке блок-схем
(алгоритм):
да
нет
x>5
y=x-8
y=x+3

Вызов функции — категория Логические
Установить курсор в ту ячейку, куда необходимо вставить функцию.
Меню «Формулы» – «Вставить функцию»
Категория — Логические
Выбрать функцию «ЕСЛИ» и ОК.
Откроется диалоговое окно «Аргументы функции» для ввода
необходимых значений
Также функция ЕСЛИ может быть записана в ячейку вручную!

Логическая функция для нашего примера
Пример. Для заданного значения x вычислить значение y
по одной из формул:
если x > 5, то y = x — 8, иначе y = x + 3.
Запись решения в электронной таблице (адреса ячеек выбираются мышью!):

Логические функции
Пример. Для заданного значения
значение y по одной из формул:
x вычислить
если x > 5, то y = x — 8, иначе y = x + 3.
Результат решения в электронной таблице после
копирования формул:
Формулы при копировании в ячейки С2, D2 принимают вид:
=ЕСЛИ(B1>5;B1-8;B1+3)
=ЕСЛИ(C1>5;C1-8;C1+3)
=ЕСЛИ(D1>5;D1-8;D1+3)

10
Функция ЕСЛИ
ЕСЛИ – выбор из двух вариантов
условие
если «да»
если «нет»
=ЕСЛИ(B2=»сдал»;
ЕСЛИ(A2>80;
5; 4); «–»)
=ЕСЛИ(A2>=70;
«сдал»;
«не сдал»)

Вопросы и задания
Оплата за аренду конференц-зала вычисляется по
следующим правилам: каждый из первых четырёх
часов аренды стоит 1000 рублей, каждый последующий
час — 750 рублей.
В ячейке В8 электронной таблицы находится
количество полных часов аренды зала.
Какая из формул позволяет подсчитать полную
стоимость аренды зала?
а) =ЕСЛИ(В8 б) = ЕСЛИ(В8 в) = ЕСЛИ(В8 г) = ЕСЛИ(В8

Вопросы и задания
Оплата за аренду конференц-зала вычисляется по
следующим правилам: каждый из первых четырёх часов
аренды стоит 1000 рублей, каждый последующий час — 750
рублей.
В ячейке В8 электронной таблицы находится количество
полных часов аренды зала.
Какая из формул позволяет подсчитать полную
стоимость аренды зала?
а) =ЕСЛИ(В8 б) = ЕСЛИ(В8 в) = ЕСЛИ(В8 г) = ЕСЛИ(В8

Функция СЧЕТЕСЛИ

Составное условие
Логические
операции
в
электронных
таблицах
представлены как функции: сначала записывается имя
логической операции, а затем в круглых скобках
перечисляются логические операнды.
• И(А1>0; A1 <10)
• ИЛИ(А1>0; A1 <10)
• НЕ(A1>0)

Функция И

И(логическое_значение1;логическое_значение2;. логическое_значение255)
Принимает значение ИСТИНА, если все аргументы имеют значение ИСТИНА.
Принимает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.

Функция ИЛИ

ИЛИ(логическое_значение1;логическое_значение2;. логическое_значение255)
Принимает значение ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА.
Принимает значение ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.

Функция НЕ

НЕ(логическое_значение)
Если аргумент «логическое_значение» имеет значение ЛОЖЬ,
функция НЕ принимает значение ИСТИНА, и наоборот.
Например: НЕ(2*2=4)

Логические операции
НЕ – обратное условие, НЕ(B2 <10)
?B2>=10
И – одновременное выполнение всех условий
=ЕСЛИ( И(B2>1994; C2>175);»да»;»–»)
23

Логические операции
24
ИЛИ – выполнение хотя бы одного из условий
=ЕСЛИ( ИЛИ(B2=100; C2=100; B2+C2>=180);»да»;»–»)

Еще примеры использования И, ИЛИ, НЕ

ЕСЛИ(И(А1>=0; В1>=0; С1>=0); «Все числа
неотрицательны»; «Есть отрицательное»);
ЕСЛИ(ИЛИ(А1 отрицательное»; «Все числа неотрицательны»);
ЕСЛИ(НЕ(И(А1>=0; В1>=0; С1>=0)); «Есть
отрицательное»; «Все числа неотрицательны»)

Какая из формул не содержит ошибок?
а) = ЕСЛИ((С4>4)И(С5>4)); «Принят!»; «Не принят»)
б) = ЕСЛИ(И(D2=0;B2/4);D3–A1; D3+A1)
в) = ЕСЛИ((A4=0 И D1 <0);1;0)
г) = ЕСЛИ(ИЛИ(A2>10;C2>10);1; «ура!»)

Какая из формул не содержит ошибок?
а) = ЕСЛИ((С4>4)И(С5>4)); «Принят!»; «Не принят»)
б) = ЕСЛИ(И(D2=0;B2/4);D3–A1; D3+A1)
в) = ЕСЛИ((A4=0 И D1 <0);1;0)
г) = ЕСЛИ(ИЛИ(A2>10;C2>10);1; «ура!»)

Задача
В ячейке A1 хранится число 10, в ячейке A2 — число 20
Определите значение в ячейках В1, В2 и В3:
B1=ЕСЛИ(A2*A1>1000;5;10);
10
B2=ЕСЛИ(ИЛИ(A114);1;2);
1
В3=ЕСЛИ(И(A1>=1;А2 <18);1;2).
2

Как вычислить плотность населения в excel формула
Найдите в справочной системе Excel раздел Фильтры, расширенные, Фильтрация списка с помощью расширенного фильтра и скопируйте содержимое этого раздела в текстовое поле. Отредактируйте размер текстового поля и текст справки.
эксперт
Мнение эксперта
Михаил Соловьев, консультант по вопросам работы с продуктами Microsoft
Если у вас возникнут сложности, я помогу разобраться!
Задать вопрос эксперту
На основе проведенных расчетов создайте новую таблицу по приведенному ниже образцу и с помощью команды меню ВСТАВКА Þ Диаграмма постройте объемную гистограмму. Если же вы хотите что-то уточнить, обращайтесь ко мне!
1.2. Используя функцию автозаполнения, заполните столбец А числами от 1 до 21, начиная с ячейки А2 и заканчивая ячейкой А22 аналогично тому, как заполнили блок ячеек годами и датами в ра­боте №1.
Средствами ms Excel Вычислите Значение Функций • Функция распределения

Урок Excel Практическая работа №2

В ячейках электронной таблицы Excel А1:А5 находятся значения аргумента х. 2. В ячейку В1 внесли формулу для расчета значений функции F ( x ), а затем «протянули» по диапазону В1:В5 с помощью маркера заполнения. Записать какие формулы будут в ячейках В1:В5. F ( x )= 3. Построить таблицу значений функции. . Задание 21 30

Понравилась статья? Поделиться с друзьями:
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!:

Adblock
detector